错误 MSB3644,未找到框架“.NETFramework,Version=v4.6.2”的引用程序集 的解决方法

Anonymity | | 访问(180)

  错误 MSB3644 未找到框架“.NETFramework,Version=v4.6.2”的引用程序集 的解决方法

  今天在研究Dapper项目时,下载代码点击生成之后报错,如下图:

  从图中可以看到报错的项目为Dapper.Tests.Perfomance,该项目的依赖项也报错的

  在网上搜索了一下解决方案,说是更改.csproj文件中的TargetFrameworks,然后打开Dapper.Tests.Performance.csproj文件,发现TargetFrameworks的值为net462,说明当前电脑环境中没有.net Framework4.6.2的版本,所以我们要将TargetFrameworks的值改为已有版本。

  如何查看当前电脑中已有的.net framework版本呢?

  很简单,打开Visual Studio,新建项目,点击选择framework版本下拉框即可看到所有的已安装framework版本啦,这里我选择4.6.1的版本(TargetFrameworks的值改为net461),重新生成项目,成功~

  文章来源:https://blog.csdn.net/qq_28839293/article/details/79179722